All vulnerabilities
GHSA-5j8x-vq8c-vrp9

ImageMagick: Information Disclosure in the postscript decoder of a single byte

ImageMagickLibraries & packages
CVSS
3.7Low
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)No scoreNo FIRST EPSS score in this snapshot yet
Fixed in7.1.2-32Fixed versionGitHub
Published27 Sep 2026Updated 27 Sep 2026GitHub

What fixes it

  • 7.1.2-32ImageMagick, c/c++GitHub

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Description

A crafted postscript file could cause an allocation of a buffer that is a single byte longer than the data it decoded resulting in possible information disclosure.

Text from GitHub Advisory Database

Affected versions 2

  • ImageMagick, c/c++< 7.1.2-32GitHub
  • ImageMagick, c/c++< 6.9.13-57GitHub