All vulnerabilities
CVE-2026-42945

NGINX ngx_http_rewrite_module vulnerability

F5 NGINX PlusWeb servers
CVSS
8.1High
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)68.0%Chance of exploitation activity in the next 30 days, higher than 99% of CVEs. Scored 25 Oct 2026FIRST EPSS
Fixed in1.30.1Fixed versionCVE List
Published13 May 2026Updated 10 Sep 2026CVE List

What fixes it

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Timeline

  1. 13 May 2026, 14:12 UTCPublishedCVE List
  2. 26 Oct 2026, 03:03 UTCExploit code publicGitHub proof-of-concept repositories

Reports 1

1 outlet mention it. Reports are not confirmation; each links to its source.

Description

NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when the rewrite directive is followed by a rewrite, if, or set directive and an unnamed Perl-Compatible Regular Expression (PCRE) capture (for example, $1, $2) with a replacement string that includes a question mark (?). An unauthenticated attacker along with conditions beyond its control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR.  Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Text from CVE List

Affected versions 5

  • NGINX Plusunaffected: R37 and laterCVE List
  • NGINX Plusaffected: R36 before R36 P4CVE List
  • NGINX Plusaffected: R32 before R32 P6CVE List
  • NGINX Open Sourceunaffected: 1.31.0 and laterCVE List
  • NGINX Open Sourceaffected: 0.6.27 before 1.30.1CVE List

References 34