All vulnerabilities
CVE-2026-42530

NGINX Open-Source ngx_http_v3_module vulnerability

F5 NGINX Open SourceWeb servers
CVSS
8.1High
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)6.45%Chance of exploitation activity in the next 30 days, higher than 93% of CVEs. Scored 27 Oct 2026FIRST EPSS
Fixed in1.31.2Fixed versionCVE List
Published17 Jun 2026Updated 16 Jul 2026CVE List

What fixes it

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Timeline

  1. 17 Jun 2026, 14:04 UTCPublishedCVE List
  2. 28 Oct 2026, 01:21 UTCExploit code publicGitHub proof-of-concept repositories

Reports 1

1 outlet mention it. Reports are not confirmation; each links to its source.

Description

NGINX Open Source has a vulnerability in the ngx_http_v3_module module. When NGINX Open Source is configured to use the HTTP/3 QUIC module, a remote unauthenticated attacker along with conditions beyond their control can use a specially crafted HTTP/3 session to reopen a QPACK encoder stream. This may cause a Use-after-Free in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR.

Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Text from CVE List

Affected versions 1

  • NGINX Open Sourceaffected: 1.31.0 before 1.31.2CVE List

References 5