CVE-2026-27975GHSA-vcw3-r3fx-j444
aj: Ajenti has potential Remote Code Execution
ajenti ajpipLibraries & packages
CVSS
8.1HighExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)0.59%Chance of exploitation activity in the next 30 days, higher than 47% of CVEs. Scored 27 Oct 2026FIRST EPSS
What fixes it
A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.
Description
Impact
An unauthenticated user could gain access to a server to execute arbitrary code on this server.
Patches
This is fixed in the version 2.2.13. Users should upgrade to this version as soon as possible.
Text from GitHub Advisory Database
Affected versions 53
- aj, pip< 2.2.13GitHub
- ajentiaffected: < 2.2.13CVE List
- aj, PyPIfrom first release, fixed in 2.2.13OSV
- aj, PyPI0.1OSV
- aj, PyPI0.10OSV
- aj, PyPI0.11OSV
- aj, PyPI0.12OSV
- aj, PyPI0.13OSV
- aj, PyPI0.14OSV
- aj, PyPI0.15OSV
- aj, PyPI0.16OSV
- aj, PyPI0.17OSV
- aj, PyPI0.18OSV
- aj, PyPI0.19OSV
- aj, PyPI0.2OSV
- aj, PyPI0.20OSV
- aj, PyPI0.21OSV
- aj, PyPI0.22OSV
- aj, PyPI0.23OSV
- aj, PyPI0.25OSV
- aj, PyPI0.26OSV
- aj, PyPI0.27OSV
- aj, PyPI0.28OSV
- aj, PyPI0.29OSV
- aj, PyPI0.3OSV
- aj, PyPI0.30OSV
- aj, PyPI0.31OSV
- aj, PyPI0.32OSV
- aj, PyPI0.33OSV
- aj, PyPI0.4OSV
- aj, PyPI0.5OSV
- aj, PyPI0.6OSV
- aj, PyPI0.7OSV
- aj, PyPI0.8OSV
- aj, PyPI0.9OSV
- aj, PyPI2.0.34OSV
- aj, PyPI2.0.35OSV
- aj, PyPI2.0.36OSV
- aj, PyPI2.0.37OSV
- aj, PyPI2.0.38OSV
- aj, PyPI2.0.39OSV
- aj, PyPI2.0.40OSV
- aj, PyPI2.0.41OSV
- aj, PyPI2.0.42OSV
- aj, PyPI2.0.43OSV
- aj, PyPI2.0.44OSV
- aj, PyPI2.0.45OSV
- aj, PyPI2.0.46OSV
- aj, PyPI2.0.47OSV
- aj, PyPI2.0.48OSV
- aj, PyPI2.0.49OSV
- aj, PyPI2.0.50OSV
- aj, PyPI2.0.51OSV