All vulnerabilities
CVE-2026-118255GHSA-6hgp-fmhr-mrg4

@highcharts/dashboards: Highcharts Grid: `javascript:` URL in credits.href runs script on click

highcharts @highcharts/dashboardsnpmLibraries & packages
CVSS
8.4High
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)No scoreNo FIRST EPSS score in this snapshot yet
Fixed in4.0.0Also 3.2.0GitHub
Published28 Oct 2026Updated 28 Oct 2026CVE List

What fixes it

  • 4.0.0@highcharts/dashboards, npmGitHubnpm install @highcharts/dashboards@4.0.0
  • 3.2.0@highcharts/grid-pro, npmGitHubnpm install @highcharts/grid-pro@3.2.0

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Description

Impact

An attacker who controls the Grid configuration can set credits.href to a javascript: URL. The value is not validated against an allowed-scheme list before it is applied to the credits link, so activating that link runs attacker-supplied script in the origin of the page hosting the Grid. Exploitation requires that untrusted data reach the Grid configuration and that a user activate the credits link. Script running this way has the same access to page data, storage and session state as the hosting application.

Workarounds

Paste in after the Grid Pro module is imported, before a Grid is created.

const { AST } = Grid;

function sanitize(options) {
    const credits = options && options.credits;

    if (credits && typeof credits.href === 'string') {
        const filtered = AST.filterUserAttributes({ href: credits.href });

        if (!filtered.href) {
            delete credits.href;
        }
    }

    return options;
}

// Both Grid.grid() and grid.update() funnel through loadUserOptions, so one
// hook covers both entry points.
const { prototype } = Grid.Grid;
const loadUserOptions = prototype.loadUserOptions;

prototype.loadUserOptions = function (options, ...rest) {
    sanitize(options);
    return loadUserOptions.call(this, options, ...rest);
};

Obtaining the patched version

The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install @highcharts/grid-lite@3.2.0. If you load Highcharts Grid from a CDN, use a versioned URL, for example https://cdn.jsdelivr.net/npm/@highcharts/grid-lite@3.2.0/grid-lite.js. For more on each installation method, see the installation guide.

Text from GitHub Advisory Database

Affected versions 7

  • @highcharts/dashboards, npm>= 3.2.0, <= 3.6.0GitHub
  • @highcharts/grid-pro, npm>= 2.0.0, <= 3.1.0GitHub
  • highchartsaffected: < 13.0.0-beta.2CVE List
  • dashboardsaffected: >= 3.2.0, < 4.0.0CVE List
  • grid-proaffected: >= 2.0.0, < 3.2.0CVE List
  • @highcharts/dashboards, npmfrom 3.2.0, fixed in 4.0.0OSV
  • @highcharts/grid-pro, npmfrom 2.0.0, fixed in 3.2.0OSV

References 5