All vulnerabilities
CVE-2026-118254GHSA-r5wg-q8fc-p6w2

@highcharts/grid-lite: Highcharts Grid parses pagination language options as HTML

highcharts @highcharts/grid-litenpmLibraries & packages
CVSS
8.6High
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)No scoreNo FIRST EPSS score in this snapshot yet
Fixed in3.2.0Fixed versionGitHub
Published28 Oct 2026Updated 28 Oct 2026CVE List

What fixes it

  • 3.2.0@highcharts/grid-lite, npmGitHubnpm install @highcharts/grid-lite@3.2.0
  • 3.2.0@highcharts/grid-pro, npmGitHubnpm install @highcharts/grid-pro@3.2.0

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Description

Impact

The pagination language strings are written into the DOM as markup rather than as text. An attacker who controls those language options can supply elements carrying event handlers, and those handlers execute in the origin of the page hosting the Grid when the pagination controls render. Exploitation requires that untrusted data reach the Grid language configuration and that pagination be enabled on the Grid.

Workarounds

Run this once after loading the Grid, before creating any grid:

{
    const Pagination = Grid.Pagination;

    const escapeLang = (pagination) => {
        const lang = pagination.lang;
        if (!lang) {
            return;
        }

        for (const key of ['pageInfo', 'pageSizeLabel']) {
            if (typeof lang[key] === 'string') {
                lang[key] = lang[key].replace(/</g, '&lt;');
            }
        }
    };

    for (const name of ['updatePageInfo', 'renderPageSizeSelector']) {
        const original = Pagination.prototype[name];

        Pagination.prototype[name] = function (...args) {
            escapeLang(this);
            return original.apply(this, args);
        };
    }
}

Obtaining the patched version

The patched releases are available from all the usual distribution channels. With npm, upgrade the affected package to the patched version listed above, for example npm install @highcharts/grid-lite@3.2.0. If you load Highcharts Grid from a CDN, use a versioned URL, for example https://cdn.jsdelivr.net/npm/@highcharts/grid-lite@3.2.0/grid-lite.js. For more on each installation method, see the installation guide.

Text from GitHub Advisory Database

Affected versions 7

  • @highcharts/grid-lite, npm>= 2.0.0, <= 3.1.0GitHub
  • @highcharts/grid-pro, npm>= 2.0.0, <= 3.1.0GitHub
  • highchartsaffected: < 13.0.0-beta.2CVE List
  • grid-liteaffected: >= 2.0.0, < 3.2.0CVE List
  • grid-proaffected: >= 2.0.0, < 3.2.0CVE List
  • @highcharts/grid-lite, npmfrom 2.0.0, fixed in 3.2.0OSV
  • @highcharts/grid-pro, npmfrom 2.0.0, fixed in 3.2.0OSV

References 4