All vulnerabilities
CVE-2026-117602GHSA-vw94-r84p-66qf

Electrum before 4.7.2 External Plugin Authorization Bypass Local Code Execution

spesmilo electrum
CVSS
8.6High
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)No scoreNo FIRST EPSS score in this snapshot yet
Fixed in4.7.2Fixed versionCVE List
Published27 Oct 2026Updated 27 Oct 2026CVE List

What fixes it

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Reports 2

1 outlet mention it. Reports are not confirmation; each links to its source.

Description

Electrum 4.6.0 before 4.7.2 contains an authorization bypass in the external plugin loader, which executes a plugin's __init__.py module when the plugin is marked enabled in the config file, without verifying its plugin-password signature. A rogue local process with write access to the Electrum data directory can place plugin code in the plugins/ folder and mark it enabled, causing arbitrary code execution inside the Electrum process.

Text from CVE List

Affected versions 2

  • electrumaffected: all versions before 4.7.2CVE List
  • electrumunaffected: 4.7.2CVE List

References 4