All vulnerabilities
CVE-2026-116871GHSA-f8vw-wvm6-h2qq

SemanticMediaWiki: Semantic MediaWiki 3.0.0 before 7.3.1 Uncontrolled Recursion via Special:Ask

SemanticMediaWiki SemanticMediaWiki
CVSS
8.7High
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)No scoreNo FIRST EPSS score in this snapshot yet
Fixed in7.3.1Fixed versionCVE List
Published27 Oct 2026Updated 27 Oct 2026CVE List

What fixes it

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Description

Semantic MediaWiki 3.0.0 before 7.3.1 contains an uncontrolled recursion vulnerability in LegacyParser::getSubqueryDescription() that processes nested query tokens before depth limits apply. Unauthenticated attackers can submit deeply nested query elements to the action=ask API to consume substantial CPU and memory, tying up request workers.

Text from CVE List

Affected versions 2

  • SemanticMediaWikiaffected: 3.0.0 before 7.3.1CVE List
  • SemanticMediaWikiunaffected: 7.3.1CVE List

References 4