All vulnerabilities
CVE-2026-116675GHSA-mf2p-h6hf-fcwm

TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` serialization

tinymce tinymcenpmLibraries & packages
CVSS
8.5High
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)No scoreNo FIRST EPSS score in this snapshot yet
Fixed in8.9.3Also 7.9.4GitHub
Published27 Oct 2026Updated 27 Oct 2026CVE List

What fixes it

  • 8.9.3tinymce, npmGitHubnpm install tinymce@8.9.3
  • 8.9.3TinyMCE, nugetGitHubdotnet add package TinyMCE --version 8.9.3
  • 8.9.3tinymce/tinymce, composerGitHubcomposer require "tinymce/tinymce:^8.9.3"
  • 7.9.4tinymce, npmGitHubnpm install tinymce@7.9.4
  • 7.9.4TinyMCE, nugetGitHubdotnet add package TinyMCE --version 7.9.4
  • 7.9.4tinymce/tinymce, composerGitHubcomposer require "tinymce/tinymce:^7.9.4"
Show all 10 fixed versions
  • 8.9.3TinyMCE, NuGetOSVdotnet add package TinyMCE --version 8.9.3
  • 8.9.3tinymce/tinymce, PackagistOSVcomposer require "tinymce/tinymce:^8.9.3"
  • 7.9.4TinyMCE, NuGetOSVdotnet add package TinyMCE --version 7.9.4
  • 7.9.4tinymce/tinymce, PackagistOSVcomposer require "tinymce/tinymce:^7.9.4"

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Description

Impact

Stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via elements crafted through the data-mce-object attribute, which are created and executed before sanitization. Impacts users of TinyMCE with the media plugin enabled.

Patches

This vulnerability has been patched in TinyMCE 8.9.3 and TinyMCE 7.9.4 by ensuring that, when using the media plugin, any content created through the data-mce-object attribute is properly sanitized first.

Workarounds

No official workaround available.

Fix

To avoid this vulnerability:

Upgrade to TinyMCE 8.9.3 or higher. Upgrade to TinyMCE 7.9.4 or higher.

Acknowledgements

Tiny thanks Fariskhi Vidyan and David Vieira Kurz (HiSolutions AG) for their help identifying this vulnerability.

Text from GitHub Advisory Database

Affected versions 35

  • tinymce, npm>= 8.5.1, < 8.9.3GitHub
  • TinyMCE, nuget>= 8.5.1, < 8.9.3GitHub
  • tinymce/tinymce, composer>= 8.5.1, < 8.9.3GitHub
  • tinymce, npm= 7.9.3GitHub
  • TinyMCE, nuget= 7.9.3GitHub
  • tinymce/tinymce, composer= 7.9.3GitHub
  • tinymceaffected: >= 8.5.1, < 8.9.3CVE List
  • tinymceaffected: >= 7.9.3, < 7.9.4CVE List
  • tinymce, npmfrom 8.5.1, fixed in 8.9.3OSV
  • TinyMCE, NuGetfrom 8.5.1, fixed in 8.9.3OSV
  • TinyMCE, NuGet8.5.1OSV
  • TinyMCE, NuGet8.6.0OSV
  • TinyMCE, NuGet8.7.0OSV
  • TinyMCE, NuGet8.8.0OSV
  • TinyMCE, NuGet8.8.1OSV
  • TinyMCE, NuGet8.8.2OSV
  • TinyMCE, NuGet8.9.0OSV
  • TinyMCE, NuGet8.9.1OSV
  • TinyMCE, NuGet8.9.2OSV
  • tinymce/tinymce, Packagistfrom 8.5.1, fixed in 8.9.3OSV
  • tinymce/tinymce, Packagist8.5.1OSV
  • tinymce/tinymce, Packagist8.6.0OSV
  • tinymce/tinymce, Packagist8.7.0OSV
  • tinymce/tinymce, Packagist8.8.0OSV
  • tinymce/tinymce, Packagist8.8.1OSV
  • tinymce/tinymce, Packagist8.8.2OSV
  • tinymce/tinymce, Packagist8.9.0OSV
  • tinymce/tinymce, Packagist8.9.1OSV
  • tinymce/tinymce, Packagist8.9.2OSV
  • tinymce, npmfrom 7.9.3, fixed in 7.9.4OSV
  • tinymce, npm7.9.3OSV
  • TinyMCE, NuGetfrom 7.9.3, fixed in 7.9.4OSV
  • TinyMCE, NuGet7.9.3OSV
  • tinymce/tinymce, Packagistfrom 7.9.3, fixed in 7.9.4OSV
  • tinymce/tinymce, Packagist7.9.3OSV

References 7