All vulnerabilities
CVE-2026-115189GHSA-h7pm-79gc-8867

mautic/core: A server-side template injection vulnerability exists in the Twig theme rendering sandbox of Mautic. The sandbox introduced to restrict user-uploaded theme templates (the fix for GHSA-9fx4-7cmj-47vg)

mautic/core
CVSS
8.8High
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)No scoreNo FIRST EPSS score in this snapshot yet
Fixed in5.2.12Also 6.0.10, 7.2.2CVE List
Published26 Oct 2026Updated 26 Oct 2026CVE List

What fixes it

  • 5.2.12CVE List
  • 6.0.10CVE List
  • 7.2.2CVE List
  • 5.2.12mautic/core, composerGitHubcomposer require "mautic/core:^5.2.12"
  • 6.0.10mautic/core, composerGitHubcomposer require "mautic/core:^6.0.10"
  • 7.2.2mautic/core, composerGitHubcomposer require "mautic/core:^7.2.2"

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Description

A server-side template injection vulnerability exists in the Twig theme rendering sandbox of Mautic. The sandbox introduced to restrict user-uploaded theme templates (the fix for GHSA-9fx4-7cmj-47vg) does not fully enforce its restrictions, allowing a crafted theme template to escape the sandbox. An authenticated user with the core:themes:create permission can upload a malicious theme whose template is later rendered, resulting in execution of arbitrary code on the server with the privileges of the web server process. This allows the attacker to execute operating system commands, read server-side files including configuration files and database credentials, write files, and reach internal services. In default installations the core:themes:create permission is granted to the Administrator role, and in multi-operator setups it may be delegated to other roles. This is an incomplete fix for GHSA-9fx4-7cmj-47vg.

Text from CVE List

Affected versions 6

  • Productaffected: 1.3.0 before 5.2.12CVE List
  • Productaffected: 6.0.0 before 6.0.10CVE List
  • Productaffected: 7.0.0 before 7.2.2CVE List
  • mautic/core, composer>= 1.3.0, < 5.2.12GitHub
  • mautic/core, composer>= 6.0.0, < 6.0.10GitHub
  • mautic/core, composer>= 7.0.0, < 7.2.2GitHub

References 1