CVE-2026-105626
Consul vulnerable to a denial of service in HTTP APIs
HashiCorp Consul
CVSS
7.5HighExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)No scoreNo FIRST EPSS score in this snapshot yet
What fixes it
A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.
Description
HashiCorp Consul and Consul Enterprise are vulnerable to a denial of service in the HTTP API that may allow an unauthenticated attacker to exhaust memory on a Consul agent. This vulnerability (CVE-2026-105626) is fixed in Consul Community Edition 2.1.0 and Consul Enterprise 2.1.0 and 1.21.19.
Text from CVE List
Affected versions 2
- Consulaffected: 0.6.0 before 2.1.0CVE List
- Consul Enterpriseaffected: 0.6.0 before 2.1.0CVE List