All vulnerabilities
CVE-2025-67895GHSA-66h8-3g48-6hx8PYSEC-2025-87PYSEC-2026-276

apache-airflow-providers-edge3: Apache Airflow Providers Edge3 exposes internal API allowing RCE in web server context

Apache Software Foundation apache-airflow-providers-edge3pipLibraries & packages
CVSS
9.8Critical
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)1.17%Chance of exploitation activity in the next 30 days, higher than 67% of CVEs. Scored 26 Oct 2026FIRST EPSS
Fixed in2.0.0Fixed versionGitHub
Published17 Dec 2025Updated 26 Oct 2026CVE List

What fixes it

  • 2.0.0apache-airflow-providers-edge3, pipGitHub
  • 2.0.0Apache Airflow Providers Edge3CVE List
  • 2.0.0apache-airflow-providers-edge3, PyPIOSVpip install "apache-airflow-providers-edge3>=2.0.0"

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Description

Edge3 Worker RPC RCE on Airflow 2.

This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if projects installed and configured it on Airflow 2.

The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if projects installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do.

If projects installed and configured Edge3 provider for Airflow 2, they should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has a minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2.

If projects used Edge Provider in Airflow 3, you they are not affected.

Text from GitHub Advisory Database

Affected versions 32

  • apache-airflow-providers-edge3, pip< 2.0.0GitHub
  • Apache Airflow Providers Edge3affected: all versions before 2.0.0CVE List
  • apache-airflow-providers-edge3, PyPIfrom first release, fixed in 2.0.0OSV
  • apache-airflow-providers-edge3, PyPI1.0.0OSV
  • apache-airflow-providers-edge3, PyPI1.0.0rc1OSV
  • apache-airflow-providers-edge3, PyPI1.0.0rc2OSV
  • apache-airflow-providers-edge3, PyPI1.1.0OSV
  • apache-airflow-providers-edge3, PyPI1.1.0rc1OSV
  • apache-airflow-providers-edge3, PyPI1.1.1OSV
  • apache-airflow-providers-edge3, PyPI1.1.1rc1OSV
  • apache-airflow-providers-edge3, PyPI1.1.2OSV
  • apache-airflow-providers-edge3, PyPI1.1.2rc1OSV
  • apache-airflow-providers-edge3, PyPI1.1.2rc2OSV
  • apache-airflow-providers-edge3, PyPI1.1.3OSV
  • apache-airflow-providers-edge3, PyPI1.1.3rc1OSV
  • apache-airflow-providers-edge3, PyPI1.2.0OSV
  • apache-airflow-providers-edge3, PyPI1.2.0rc1OSV
  • apache-airflow-providers-edge3, PyPI1.3.0OSV
  • apache-airflow-providers-edge3, PyPI1.3.0rc1OSV
  • apache-airflow-providers-edge3, PyPI1.3.1OSV
  • apache-airflow-providers-edge3, PyPI1.3.1rc1OSV
  • apache-airflow-providers-edge3, PyPI1.4.0OSV
  • apache-airflow-providers-edge3, PyPI1.4.0rc1OSV
  • apache-airflow-providers-edge3, PyPI1.4.1OSV
  • apache-airflow-providers-edge3, PyPI1.4.1rc1OSV
  • apache-airflow-providers-edge3, PyPI1.4.1rc2OSV
  • apache-airflow-providers-edge3, PyPI1.5.0OSV
  • apache-airflow-providers-edge3, PyPI1.5.0rc1OSV
  • apache-airflow-providers-edge3, PyPI1.6.0OSV
  • apache-airflow-providers-edge3, PyPI1.6.0rc1OSV
  • apache-airflow-providers-edge3, PyPI1.6.0rc2OSV
  • apache-airflow-providers-edge3, PyPI2.0.0rc1OSV

References 7