CVE-2023-25693GHSA-j69x-v4wc-3fpfPYSEC-2023-314PYSEC-2026-275
apache-airflow-providers-apache-sqoop: Apache Airflow Sqoop Provider Improper Input Validation vulnerability
Apache Software Foundation apache-airflow-providers-apache-sqooppipLibraries & packages
CVSS
9.8CriticalExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)1.90%Chance of exploitation activity in the next 30 days, higher than 79% of CVEs. Scored 26 Oct 2026FIRST EPSS
What fixes it
- 3.1.1apache-airflow-providers-apache-sqoop, pipGitHub
- 3.1.1Apache Airflow Sqoop ProviderCVE List
- 3.1.1apache-airflow-providers-apache-sqoop, PyPIOSV
pip install "apache-airflow-providers-apache-sqoop>=3.1.1"
A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.
Description
Improper Input Validation vulnerability in the Apache Airflow Sqoop Provider. This issue affects Apache Airflow Sqoop Provider versions before 3.1.1.
Text from CVE List
Affected versions 32
- apache-airflow-providers-apache-sqoop, pip< 3.1.1GitHub
- Apache Airflow Sqoop Provideraffected: all versions before 3.1.1CVE List
- apache-airflow-providers-apache-sqoop, PyPIfrom first release, fixed in 3.1.1OSV
- apache-airflow-providers-apache-sqoop, PyPI1.0.0OSV
- apache-airflow-providers-apache-sqoop, PyPI1.0.0b1OSV
- apache-airflow-providers-apache-sqoop, PyPI1.0.0b2OSV
- apache-airflow-providers-apache-sqoop, PyPI1.0.0rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI1.0.1OSV
- apache-airflow-providers-apache-sqoop, PyPI1.0.1rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI2.0.0OSV
- apache-airflow-providers-apache-sqoop, PyPI2.0.0rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI2.0.0rc2OSV
- apache-airflow-providers-apache-sqoop, PyPI2.0.1OSV
- apache-airflow-providers-apache-sqoop, PyPI2.0.1rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI2.0.1rc2OSV
- apache-airflow-providers-apache-sqoop, PyPI2.0.2OSV
- apache-airflow-providers-apache-sqoop, PyPI2.0.2rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI2.1.0OSV
- apache-airflow-providers-apache-sqoop, PyPI2.1.0rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI2.1.0rc2OSV
- apache-airflow-providers-apache-sqoop, PyPI2.1.1OSV
- apache-airflow-providers-apache-sqoop, PyPI2.1.1rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI2.1.2OSV
- apache-airflow-providers-apache-sqoop, PyPI2.1.2rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI2.1.3OSV
- apache-airflow-providers-apache-sqoop, PyPI2.1.3rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI3.0.0OSV
- apache-airflow-providers-apache-sqoop, PyPI3.0.0rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI3.0.0rc2OSV
- apache-airflow-providers-apache-sqoop, PyPI3.1.0OSV
- apache-airflow-providers-apache-sqoop, PyPI3.1.0rc1OSV
- apache-airflow-providers-apache-sqoop, PyPI3.1.1rc1OSV
References 7
- github.com/apache/airflow/pull/29500Fixvia CVE List
- lists.apache.org/thread/79qn8g5xbq036f8crb115obvr22l52q4Advisoryvia CVE List
- github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-314.yamlAdvisoryvia GitHub
- github.com/pypa/advisory-database/tree/main/vulns/apache-airflow-providers-apache-sqoop/PYSEC-2026-275.yamlAdvisoryvia GitHub
- github.com/advisories/GHSA-j69x-v4wc-3fpfAdvisoryvia GitHub
- nvd.nist.gov/vuln/detail/CVE-2023-25693Referencevia GitHub
- pypi.org/project/apache-airflow-providers-apache-sqoopReferencevia GitHub