All vulnerabilities
CVE-2021-4171GHSA-xp7p-3gx7-j6wxPYSEC-2026-307

calibreweb: calibre-web is vulnerable to Business Logic Errors

janeczku calibrewebpipLibraries & packages
CVSS
9.8Critical
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)1.39%Chance of exploitation activity in the next 30 days, higher than 72% of CVEs. Scored 27 Oct 2026FIRST EPSS
Fixed in0.6.15Fixed versionGitHub
Published17 Jan 2022Updated 27 Oct 2026CVE List

What fixes it

  • 0.6.15calibreweb, pipGitHub
  • 0.6.15janeczku/calibre-webCVE List
  • 0.6.15calibreweb, PyPIOSVpip install "calibreweb>=0.6.15"

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Description

calibre-web is vulnerable to Business Logic Errors

Text from CVE List

Affected versions 6

  • calibreweb, pip< 0.6.15GitHub
  • janeczku/calibre-webaffected: unspecified before 0.6.15CVE List
  • calibreweb, PyPIfrom first release, fixed in 0.6.15OSV
  • calibreweb, PyPI0.6.12OSV
  • calibreweb, PyPI0.6.13OSV
  • calibreweb, PyPI0.6.14OSV

References 6