All vulnerabilities
CVE-2018-10931GHSA-8787-63px-3m23PYSEC-2026-313

Cobbler has Exposed Dangerous Method or Function

The Cobbler Project cobblerpipLibraries & packages
CVSS
9.8Critical
ExploitationNo known exploitationNot in CISA KEV, which does not prove it is unexploitedCISA KEV
Exploit odds (EPSS)68.1%Chance of exploitation activity in the next 30 days, higher than 99% of CVEs. Scored 27 Oct 2026FIRST EPSS
Fixed in3.0.0Fixed versionGitHub
Published9 Aug 2018Updated 27 Oct 2026CVE List

What fixes it

  • 3.0.0cobbler, pipGitHub
  • 3.0.0cobbler, PyPIOSVpip install "cobbler>=3.0.0"

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Description

It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface class over XMLRPC. A remote, unauthenticated attacker could use this flaw to gain high privileges within cobbler, upload files to arbitrary location in the context of the daemon.

Text from CVE List

Affected versions 3

  • cobbler, pip>= 2.6.0, < 3.0.0GitHub
  • cobbleraffected: 2.6.xCVE List
  • cobbler, PyPIfrom 2.6.0, fixed in 3.0.0OSV

References 18