All vulnerabilities
CVE-2018-1000226GHSA-f88q-22g8-frcgPYSEC-2026-315

Cobbler Improper Validation of Security Tokens

n/a cobblerpipLibraries & packages
CVSS
9.8Critical
ExploitationScanner template publicA Nuclei template detects it. Not in the KEV catalogNuclei
Exploit odds (EPSS)12.6%Chance of exploitation activity in the next 30 days, higher than 96% of CVEs. Scored 27 Oct 2026FIRST EPSS
Fixed in3.0.0Fixed versionGitHub
Published20 Aug 2018Updated 27 Oct 2026CVE List

What fixes it

  • 3.0.0cobbler, pipGitHub
  • 3.0.0cobbler, PyPIOSVpip install "cobbler>=3.0.0"

A fixed version on one release line is not the upgrade target for every line. Check your exact version and any vendor backports.

Public exploit code and templates 1

  • Scanner templateCobbler - Authentication BypassNuclei

Listed so defenders can prioritize. Threatline links to the source and does not host exploit code.

Description

Cobbler version Verified as present in Cobbler versions 2.6.11+, but code inspection suggests at least 2.0.0+ or possibly even older versions may be vulnerable contains a Incorrect Access Control vulnerability in XMLRPC API (/cobbler_api) that can result in Privilege escalation, data manipulation or exfiltration, LDAP credential harvesting. This attack appear to be exploitable via "network connectivity". Taking advantage of improper validation of security tokens in API endpoints. Please note this is a different issue than CVE-2018-10931.

Text from CVE List

Affected versions 4

  • cobbler, pip<= 2.6.11GitHub
  • n/aaffected: n/aCVE List
  • cobbler, PyPIfrom first release, fixed in 3.0.0OSV
  • cobbler, PyPI0.6.3-2OSV

References 7